Busy. Please wait.
or

show password
Forgot Password?

Don't have an account?  Sign up 
or

Username is available taken
show password

why


Make sure to remember your password. If you forget it there is no way for StudyStack to send you a reset link. You would need to create a new account.
We do not share your email address with others. It is only used to allow you to reset your password. For details read our Privacy Policy and Terms of Service.


Already a StudyStack user? Log In

Reset Password
Enter the associated with your account, and we'll email you a link to reset your password.

Remove ads
Don't know
Know
remaining cards
Save
0:01
To flip the current card, click it or press the Spacebar key.  To move the current card to one of the three colored boxes, click on the box.  You may also press the UP ARROW key to move the card to the "Know" box, the DOWN ARROW key to move the card to the "Don't know" box, or the RIGHT ARROW key to move the card to the Remaining box.  You may also click on the card displayed in any of the three boxes to bring that card back to the center.

Pass complete!

"Know" box contains:
Time elapsed:
Retries:
restart all cards




share
Embed Code - If you would like this activity on your web page, copy the script below and paste it into your web page.

  Normal Size     Small Size show me how

Instrucciones Karel

Diciéndole a Karel que hacer

QuestionAnswer
¿Qué son las instrucciones o comandos? Es la forma en que le decimos a Karel que es lo que tiene que hacer
¿Qué es un programa? Es un conjunto de instrucciones que indican a Karel que es lo que tienen que hacer
¿Dónde se crea un programa para Karel? Para ello utilizaremos la pestaña PROGRAMA del simulador Karel y presionamos NUEVO allí escribiremos las instrucciones
¿Cuál es la estructura de un programa en Karel? iniciar-programa inicia-ejecucion <instrucciones> apagate; termina-ejecucion finalizar-programa
¿Cuáles son las instrucciones básicas en Karel? 1. avanza (avanza una esquina) 2. gira-izquierda (gira hacia la izquierda 90 grados) 3.coge-zumbador (recoge un zumbador) 4. deja-zumbador (deja un zumbador) 5. apagate (desconecta el robot)
¿Qué indica un punto y coma al final de cada instrucción? La terminación de una instrucción
¿Cuál es el paso siguiente después de escribir un programa? Compilarlo,lo cual implica que se revisará el programa en busca de errores de sintaxis y a su vez se transformaran esas instrucciones en código máquina que karel ejecutará (botón COMPILAR)
¿Qué pasa si el compilador indica que el programa tiene errores? Será necesario revisar la forma en que se escribieron las instrucciones, corregir y volver a compilar.
¿Cada cuando hay que compilar un programa? Cada vez que se crea por primera vez y/o sufra alguna modificación
¿Qué sigue cuando al compilar nuestro programa no se detectan errores? Ahora se tendrá que ejecutar el programa y ver que los resultados obtenidos corresponden a lo deseado. (botón EJECUTAR)
¿Qué hago si los resultados obtenidos no eran los deseados? Bueno esto indica que aunque nuestro programa no tiene errores nuestro algoritmo de solución no es el apropiado, así que es necesario replantearlo
Created by: anunez